Gearbest Banner

Author Topic: Linksys 4200 with Tomato won't pull DHCP address...  (Read 1200 times)

Offline Arinoth

  • Here I Am. Here I Remain
  • Admin
  • Sr. Member
  • *****
  • Posts: 494
  • Karma: 5
    • View Profile
Linksys 4200 with Tomato won't pull DHCP address...
« on: October 15, 2015, 07:36:28 AM »
So I am trying to cut out the horrible Actiontec Router/Modem that Bell Aliant uses as for whatever reason they are unable to get port forwarding to work, advanced dmz to allow my commercial router to port forward, and bridge mode bricks it until I do a factory reset.

So I have been able to get Tomato by Shibby onto my Linksys E4200 in order to set the VLAN to 35 on it (That's what Bell Aliant uses), however after releasing the IP address from the Actiontec and wiring up the E4200 it forever looks for the DCHP, never grabbing it and thus no internet.

I am not sure if I am doing it right, though I HAVE been following quite a few online guides, I'll include a picture of my configuration page shortly.


Offline TheDarkLord

  • Full Member
  • ***
  • Posts: 121
  • Karma: 1
    • View Profile
Re: Linksys 4200 with Tomato won't pull DHCP address...
« Reply #1 on: October 15, 2015, 11:45:19 AM »
I don't know how Bell operates but setting the vlan to 35 might be more complicated that you think.
If (i'm only guessing here) they have it locked down to a MAC address (which would be stupid but it is Bell after all), you'll have to spoof your MAC to make it pass through port security (again, stupid if Bell statically assigns MAC addresses to ports).
Another thing would be the "ip helper address" (basically your default gateway on the router), that you will need to setup.
Best option would be, plug in the old router and take a screen shot of all the configs then we can try and figure it out from there.

Real Hardware Reviews

Re: Linksys 4200 with Tomato won't pull DHCP address...
« Reply #1 on: October 15, 2015, 11:45:19 AM »

Offline Arinoth

  • Here I Am. Here I Remain
  • Admin
  • Sr. Member
  • *****
  • Posts: 494
  • Karma: 5
    • View Profile
Re: Linksys 4200 with Tomato won't pull DHCP address...
« Reply #2 on: October 15, 2015, 11:56:23 AM »
I don't know how Bell operates but setting the vlan to 35 might be more complicated that you think.
If (i'm only guessing here) they have it locked down to a MAC address (which would be stupid but it is Bell after all), you'll have to spoof your MAC to make it pass through port security (again, stupid if Bell statically assigns MAC addresses to ports).
Another thing would be the "ip helper address" (basically your default gateway on the router), that you will need to setup.
Best option would be, plug in the old router and take a screen shot of all the configs then we can try and figure it out from there.


Bell in Ontario/Quebec require the MAC address, however I have cloned the MAC address of my modem anyway and there are no real configuration with the modem, it's set to DHCP and that's it.

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal