Gearbest Banner

Author Topic: missing screws 7970  (Read 1302 times)

Offline clshades

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
    • View Profile
missing screws 7970
« on: February 26, 2014, 10:09:27 PM »
So I'm attempting to put back together some video card stuff for a friend whos kid may or may not have flushed them down the toilet. It's all just really heart breaking to me... such a good card.

missing original screws from the fan cooling on an HIS 7970 reference card
missing backplate screws from EK 7970 backpate (no idea on the size length etc)
missing pressure plate for the 7970 behind the gpu die rear of card. (maybe it never existed)
missing 2 front bezzle plate screws where the monitors plug in DVI ports... (they are tiny tiny)

It appears as though the rear screws on the 7970 are all spring style but I don't know for sure because I didn't take it apart originally. The owner put on an xspc water block and then attempted to replace the air cooling with the water block screw set. While the card wasn't severely overheating it certainly wasn't running to it's potential. Several screws were missing... sigh.

Where to find the screws and springs for an HIS 7970 reference. The pressure plate wasn't on there so I'm assuming it may be missing as well.

It breaks my heart to see someone do such a shitty job of putting a card back together. Hoping I can salvage this thing and I already sent a request to HIS to see if they can help at all.

Any input or opinions welcome...

Offline Fudd Rucker

  • Newbie
  • *
  • Posts: 29
  • Karma: 0
  • I am awesomeness incarnate
    • View Profile
Re: missing screws 7970
« Reply #1 on: February 27, 2014, 10:40:12 AM »
Is contacting the OEM to see about purchasing the mounting hardware again an option? Or a third party cooler might be the other option.

Real Hardware Reviews

Re: missing screws 7970
« Reply #1 on: February 27, 2014, 10:40:12 AM »

Offline clshades

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
    • View Profile
Re: missing screws 7970
« Reply #2 on: March 02, 2014, 07:17:52 AM »
found all the screws except one and pillaged a tiny small one off some other unused hardware. What a pain in the ass...

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal