Gearbest Banner

Author Topic: OCZ...  (Read 739 times)

Offline Adzsask

  • Newbie
  • *
  • Posts: 28
  • Karma: 0
    • View Profile
OCZ...
« on: November 19, 2014, 12:33:40 PM »
Was going through my box of aging hardware, and stumbled on my old agility 3 SSD. Saw it still has some warranty and decided to set up an RMA. After having a useless drive sitting in storage for over one full year, they tell me FINALLY, to update my firmware (set up an RMA almost a year ago, no firmware updates were mentioned). The "manager" who replied was beyond rude, and pretty much told me to bad, so sad. They will be added to my "never supporting again" list along with a few other companies (looking at you gigabyte >:( ) Right around the time this drive just disappeared from my device manager, the firmware update was released, I was told I was sent an email, so I went through over 72 pages of old emails to find it....never happened. Also, they said the URL for the update was on the warranty form, again it is not there...really know how to leave a sour taste in a guys mouth.

Online Soullessone21

  • [ЯHR]Co-Owner
  • Admin
  • Hero Member
  • *****
  • Posts: 2030
  • Karma: 19
    • View Profile
Re: OCZ...
« Reply #1 on: November 19, 2014, 12:53:26 PM »
Damn that sounds less than fun to deal with,

I have or maybe had he might of left, a great OCZ RMA rep, if you want me to give that drive another shot with them pm me the serial number and I will talk with them:)

I had them rma a box of 20 drives with next to no questions they upgraded everyone of them and it was awesome.

-John

PS Gigabyte.... RMA services of the world rejoice due to the fact they can all say "At least we are not as bad as Gigabyte" haha
Real Hardware Reviews is always accepting guest reviewers, email me if your interested.


BTC Donation wallet"Help me help you" 1D7KcRyxunyjmN6mR8uMx6xQ1LoWmu24CQ

Real Hardware Reviews

Re: OCZ...
« Reply #1 on: November 19, 2014, 12:53:26 PM »

Offline Adzsask

  • Newbie
  • *
  • Posts: 28
  • Karma: 0
    • View Profile
Re: OCZ...
« Reply #2 on: November 19, 2014, 01:07:28 PM »
Drive was apparently working fine the whole time....but I was not aware of the firmware update. Under 600 hours use, the SSD I replaced it with is 5 months newer, and has over 5500 hours use . Thanks for the offer, you are much to kind in that regard.

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal