Failed build - Bitfenix Merc Alpha

Bitfenix Merc case is made in two versions - Beta with no top/side performations and Alpha with them. I choose the later:

The aim was to rebuild my old Sapphire "Grouper" A9RX480 mainboard machine with Opteron 148 CPU (capable of going from 2.2GHz to 2.8GHz) and some older HW to once again work as my main PC.

I was mostly conserned, if the cables for the CPU 12V line will fit. They did. Enermax 620W Liberty (recapped) PSU was properly tested in friend machine and same goes for the OCZ 2x 1024MB OCZP4001G rams, the POW 8600GT and the HDD (320G Seagate 16MB cache (ST3320620A) with the 30G SSD Corsair Nova 2 SSD aimed for the OS drive.

So the build went on like this:

…and despite the PATA cables and floppy drive cables are huge, I think I made fairly good job. The default cooling on the POW 8600GT is noisy, but I was considering replacing it with modified Arctic Cooling VGA cooler.

The main problem is, sadly, that the mainboard still refuse to work properly. Sometimes at all. When I try to set 1T access to the rams or anything like that, then no post. Same with rams set at auto AND higher FSB. No post. Always it end by reseting the bios.

At auto memory settings (+ voltage bump to 2.66V) it does work (2T access, slow timings) for some time and then it start crashing by most basic things... 😞

And this was a mainboard, that once set, run ROCK STABLE for me 😞 That was, until
2008, then it was abandoned to 2012 and then using the same components it just won't work stable anymore. Weird. It was stable...

All issues aside that board looks awesome, looks just like a super retro mobo.

Hope the issues and delivery show up soon buddy

Thanks! Yes, the mobo looks awesome and it worked awesome too. Sure it did not have the power to move todays games (2.8GHz Opteron 148, 2G ram, 8600 GTX), but it was a decent machine never the less. Sadly I still was not managed to get it working.

I flashed the special latest modified bios I was using in the mobo and now the mobo refuse to get past posting at all. Interesting. I hope it is just bios chip wrong or something like that, because I would still like to use the mobo as backup machine and nice old timer. It worked for me so well for so long time…  πŸ˜›

And the delivery should be cleared from customs already, so there will be another build then - let's hope I did not need to canibalize this one to get it done - and I think (if the mainboard is stable) that next build should be working one, not fail as this one ATM is.